HDU - 3555 Bomb(数位dp)

Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 22706    Accepted Submission(s): 8539


 

Problem Description

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

 

Input

The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.

 

Output

For each test case, output an integer indicating the final points of the power.

 

Sample Input

 

3 1 50 500

 

Sample Output

 
0 1 15

Hint

From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.  

Author

fatboy_cw@WHU

 

Source

2010 ACM-ICPC Multi-University Training Contest(12)——Host by WHU

 

Recommend

zhouzeyong

求n以内有多少个包含49的数字,可以用数位dp求出不包含的,再用总数减去就行了,注意求不包含的会包括零,所以是n-solve(n)+1

数位dp是看了大佬的博客学的,写的很详细:https://blog.csdn.net/wust_zzwh/article/details/52100392

#include <iostream>
#include <cstdlib>
#include <cstring>
using namespace std;
typedef long long ll;

int a[50];
ll dp[50][2];//2是状态数,前导是4是状态1,否则是状态0;

ll dfs(int pos,bool sta,bool limit){
//pos是当前位数,sta是状态(前导是否为0),limit是数位上界变量(数位上界是否有限制)
    if(pos == -1) return 1;//pos从高位算起,此时说明这个数位全部合法
    if(!limit && dp[pos][sta]!=-1) return dp[pos][sta];//数位上界没有限制和有限制不一定一样
    int up = limit? a[pos] : 9;//up为数位上界
    ll ans = 0;
    for(int i = 0;i <= up;i++){
        if(sta && i == 9) continue;//包含49
        ans += dfs(pos-1,i==4,limit && i == a[pos]);
    }
    if(!limit) dp[pos][sta] = ans;
    return ans;
}

ll solve(ll x){
    int pos = 0;
    while(x){
        a[pos++] = x%10;
        x /= 10;
    }
    return dfs(pos-1,0,1);
}

int main()
{
    int t;
    cin >> t;
    memset(dp,-1,sizeof(dp));
/*
这个放在外面比放在里面省时,之所以可以放在外面,是因为数位dp里面利用的是数位自身的属性,比如49里面含49,不会因为给的范围改变了就改变这个属性,只是看给的范围里面包不包括49,
*/
    while(t--){
        ll n;
        cin >> n;
        cout << n - solve(n)+1 << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_42754600/article/details/81530610
今日推荐