Bomb HDU - 3555(数位DP)

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

Input The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
Output For each test case, output an integer indicating the final points of the power. Sample Input
3
1
50
500
Sample Output
0
1
15


        
  
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499",
so the answer is 15.
        
 
数位DP裸题
初始化不要忘
code:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
typedef long long ll;
ll dp[30][10][2];//dp[pos][pre][yes]
int digit[30];
ll dfs(int pos,int pre,int yes,int limit){
    if(pos == -1) return yes;
    ll &dpnow = dp[pos][pre][yes];
    if(!limit && dpnow != -1) return dpnow;
    int max_digit = limit ? digit[pos] : 9;
    ll ans = 0;
    for(int i = 0; i <= max_digit; i++){
        if(yes)
          ans += dfs(pos - 1, i, 1, limit && i == max_digit);
        else
          ans += dfs(pos - 1, i, pre == 4 && i == 9, limit && i == max_digit);
    }
    if(!limit)
        dpnow = ans;
    return ans;
}
ll solve(ll n){
    int pos = 0;
    while(n){
        digit[pos++] = n % 10;
        n /= 10;
    }
    return dfs(pos-1,0,0,1);
}
int main(){
    int t;
    scanf("%d",&t);
    memset(dp,-1,sizeof(dp));
    while(t--){
        ll n;
        scanf("%lld",&n);
        printf("%lld\n",solve(n));
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/codeswarrior/article/details/80502457