Bomb//HDU - 3555//数位dp

Bomb//HDU - 3555//数位dp


题目

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence “49”, the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
Output
For each test case, output an integer indicating the final points of the power.
Sample Input
3
1
50
500
Sample Output
0
1
15
Hint
From 1 to 500, the numbers that include the sub-sequence “49” are “49”,“149”,“249”,“349”,“449”,“490”,“491”,“492”,“493”,“494”,“495”,“496”,“497”,“498”,“499”,
so the answer is 15.
题意
只要49
链接:https://vjudge.net/contest/349029#problem/K

思路

数位dp模板,同“不要62”

代码

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
typedef long long ll;
ll n, dp[25][3];
ll digit[25];
ll dfs(ll pos, ll temp, ll limit)
{
    if(pos <= 0)
        return temp==2;           //看是否为49
    if(!limit && dp[pos][temp]!=-1)
        return dp[pos][temp];
    ll ans = 0;
    ll endn = limit?digit[pos]:9;    // 确定上限
    for(ll i = 0; i <= endn; i++){   //分别枚举3种情况
        ll tempn=temp;
        if(temp==0 && i==4)
            tempn = 1;
        else if(temp==1 && i!=4 && i!=9)
            tempn = 0;
        else if(temp==1 && i==9)
            tempn = 2;
        ans+=dfs(pos-1, tempn, limit && i==endn);
    }
    if(!limit)
        dp[pos][temp]=ans;
    return ans;
}

ll cal(ll x){
    ll cnt = 0;
    while(x){
        digit[++cnt] = x%10;
        x/=10;
    }
    digit[cnt+1] = 0;
    return cnt;
}

int main(){
    ll t;
    scanf("%lld",&t);
    while(t--){
        memset(dp,-1,sizeof(dp));
        scanf("%lld",&n);
        ll len = cal(n);
        printf("%lld\n",dfs(len, 0, 1));
    }
    return 0;
}

注意

发布了50 篇原创文章 · 获赞 19 · 访问量 2583

猜你喜欢

转载自blog.csdn.net/salty_fishman/article/details/104245612