FatMouse’ Trade

版权声明:© 2020 • OmegaXYZ.com-版权所有 转载请注明出处 https://blog.csdn.net/xyisv/article/details/89372653

简介

贪心算法(又称贪婪算法)是指,在对问题求解时,总是做出在当前看来是最好的选择。也就是说,不从整体最优上加以考虑,他所做出的是在某种意义上的局部最优解。
贪心算法不是对所有问题都能得到整体最优解,关键是贪心策略的选择,选择的贪心策略必须具备无后效性,即某个状态以前的过程不会影响以后的状态,只与当前状态有关。

FatMouse’ Trade

FatMouse’ Trade

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 33703 Accepted Submission(s): 10981

Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

Sample Output

13.333
31.500

贪心思想

从每傍食物最便宜的开始

C++代码

#include<iostream>
#include<algorithm>
 
using namespace std;
 
struct bean{
    double pound;
    double value;
    double perv;
    bool operator < (const bean &A)const{
        return perv > A.perv;
    }
}buff[100];
 
int main(){
    int n;
    double m;
    while(cin>>m>>n){
        if(m == -1 && n == -1)break;
        for(int i = 0; i < n; i++){
            scanf("%lf%lf", &buff[i].pound, &buff[i].value);
            buff[i].perv = buff[i].pound/buff[i].value;
        }
        sort(buff, buff + n);
        int id = 0;
        double ans = 0;
        while(m > 0 && id < n){
            if(m > buff[id].value){
                m -= buff[id].value;
                ans += buff[id].pound;
            }else{
                ans += m*buff[id].perv;
                m = 0;
            }
            id++;
        }
        cout<<ans<<endl;
    }
    return 0;
}
/*
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
*/

猜你喜欢

转载自blog.csdn.net/xyisv/article/details/89372653
今日推荐