HDU 1009(FatMouse' Trade)

版权声明:本人原创,转载请注明出处! https://blog.csdn.net/qq_29117927/article/details/86610053
												FatMouse' Trade
			Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
						Total Submission(s): 101906    Accepted Submission(s): 35540

Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

Sample Output
13.333
31.500

#include<iostream>
#include<algorithm>
#include<stdio.h>
using namespace std;
typedef struct student{
    int a,b;
    double c;
};
bool com(const student &s1,const student &s2)
{
    if((s1.c*1000)>(s2.c*1000))
        return true;
    else
        return false;
}
int main()
{
    int n,m,i;
    double t=0;
    student s[1000];
    while(cin>>n>>m)
    {
        if(n==-1&&m==-1)
        {
            break;
        }
        for(i=0;i<m;i++)
        {
            cin>>s[i].a>>s[i].b;
            s[i].c=s[i].a*1.0/s[i].b;
        }
        sort(s,s+m,com);
        for(i=0;i<m;i++)
        {
            if(n>=s[i].b)
            {
                t=t+s[i].a;
                n=n-s[i].b;
            }
            else
            {
                if(n<s[i].b&&n>0)
                {
                    t=t+s[i].c*n;
                    n=0;
                }
                else
                {
                    break;
                }
            }
        }
        printf("%.3lf\n",t);
        t=0;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_29117927/article/details/86610053
今日推荐