1009 HDU FatMouse' Trade

Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

 

5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1

Sample Output

 

13.333 31.500

#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
#include<cstdio>
using namespace std;
struct node
{
    int j;
    int f;
    double p;
}ac[100006];
bool cmp(node a,node b)
{
    return a.p>b.p;
}
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)&&n!=-1&&m!=-1)
    {
        for(int i=0;i<m;i++)
        {
                scanf("%d%d",&ac[i].j,&ac[i].f);
                ac[i].p=1.0*ac[i].j/ac[i].f;
        }
        sort(ac,ac+m,cmp);
        int rest=n;
        double ans=0.0;
        for(int i=0;i<m;i++)
        {
            //printf("%.2lf ",ac[i].p);
            if(rest>=ac[i].f) {ans+=1.0*ac[i].j;rest-=ac[i].f;}
            else
            {
                ans+=double(1.0*ac[i].j/ac[i].f)*rest;
                break;
            }
        }
        printf("%.3lf\n",ans);

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41453511/article/details/81978798