HDU 1009 FatMouse' Trade(简单贪心)

传送门:

http://acm.hdu.edu.cn/showproblem.php?pid=1009

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 93676    Accepted Submission(s): 32566


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 
Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 
Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 
Sample Input
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 
Sample Output
13.333 31.500
 
Author
CHEN, Yue
 
Source
 
Recommend
JGShining   |   We have carefully selected several similar problems for you:   1051  1052  1049  2187  1001 
 
题目意思:
一共有n个房子,每个房子里有老鼠喜欢吃的javabeans,但是每个房间里的javabeans的价格不一样。老鼠用m元,问m元最多可以卖多少javabeans,其中每个房间里的javabeans可以被分割。
 
分析:按照单价排序(价值除以重量),一直选择单价最大的的全部,当不能选择全部的时候,选择一部分
 
code:
#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<queue>
#include<set>
#include<map>
#include<string>
#include<memory.h>
#include<math.h>
#define eps 1e-7
using namespace std;
#define max_v 1005
struct node
{
    double v,c;
}p[max_v];
bool cmp(node a,node b)
{
    return (a.v/a.c)>(b.v/b.c);//单价
}
int main()
{
    int n,m;
    double sum;
    int i;
    while(cin>>m>>n)
    {
        if(n==-1&&m==-1)
            break;
        for(i=0;i<n;i++)
            cin>>p[i].v>>p[i].c;
        sort(p,p+n,cmp);
        sum=0;
        for(i=0;i<n;i++)
        {
            if(m>=p[i].c)
            {
                sum+=p[i].v;
                m-=p[i].c;
            }else
            {
                sum+=(m*(p[i].v/p[i].c));
                break;
            }
        }
        printf("%0.3lf\n",sum);
    }
    return 0;
}
 
 

猜你喜欢

转载自www.cnblogs.com/yinbiao/p/9398167.html
今日推荐