【贪心】FatMouse' Trade

描述

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

输入

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.

输出

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

样例输入

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

样例输出

13.333
31.500

分析:
简单的贪心问题,不过不用翻译的话得理解题意。
代码:
#include<bits/stdc++.h>
using namespace std;
#define N 1010
int n,m;
struct node
{
double J;
double F;
double P;//J:F
}a[N];
bool cmp(node x,node y)
{
return x.P>y.P;
}
int main()
{
int n,m;
while(cin>>n>>m)
{
double ans;
if (n==-1&&m==-1) break;
for (int i=0;i<m;i++)
{
cin>>a[i].J>>a[i].F;
a[i].P=1.0a[i].J/a[i].F;
}
sort(a,a+m,cmp);
ans=0;
for (int i=0;i<m;i++)
{
if (n==0) break;//特殊情况
if (a[i].F<=n)
{
n-=a[i].F;
ans+=a[i].J;
}
else
{
ans+=1.0
n*a[i].P;
break;
}
}
printf("%.3lf\n",ans);
}
return 0;
}

发布了65 篇原创文章 · 获赞 0 · 访问量 1321

猜你喜欢

转载自blog.csdn.net/Skynamer/article/details/104040163