HDU-1009——FatMouse' Trade

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/kongsanjin/article/details/84836185

                                        FatMouse' Trade

Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

5 3

7 2

4 3

5 2

20 3

25 18

24 15

15 10

-1 -1

Sample Output

13.333

31.500

题意描述:

老鼠手里总共有n个房间,m个猫粮,每个房间不同数量的老鼠喜欢的食物,想要获得食物就要给猫猫粮。给出了每个房间的老鼠食物的食物量,及所对应需要的猫粮。可以给少于对应房间的猫粮,当然得到的食物也是对应比例的。求能获得最大喜欢食物的量。

解题思路:

简单的贪心,求出每个房间每个猫粮的价值,根据价值进行排序。从价值最大的开始换取,当不够把一个房间的食物换完是,换取对比例的食物。

程序代码:

#include<stdio.h>
#include<algorithm>
using namespace std;
struct A
{
	int a;
	int b;
	double c;
}q[1010];
double cmp(struct A a,struct A b)
{
	return a.c>b.c;
}
int main()
{
	int n,m,i,j;
	double sum;
	while(scanf("%d%d",&m,&n))
	{
		if(m==-1&&n==-1)
			break;
		sum=0;
		for(i=1;i<=n;i++)
		{
			scanf("%d%d",&q[i].b,&q[i].a);
			q[i].c=q[i].b*1.0/q[i].a;
		}
		sort(q+1,q+n+1,cmp);
		for(i=1;i<=n;i++)
		{
			if(q[i].a<=m)
			{
				m=m-q[i].a;
				sum+=q[i].b;
			}
			else
			{
				sum+=m*q[i].c;
				break;
			}
		}
		printf("%.3f\n",sum);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/kongsanjin/article/details/84836185
今日推荐