HDU 1009 FatMouse' Trade(贪心)

FatMouse’ Trade
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 93617 Accepted Submission(s): 32537

Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

Sample Output
13.333
31.500

#include<bits/stdc++.h>
using namespace std;
struct node
{
    double j;
    double f;
    double val;
}p[1005];
bool cmp(node a,node b)
{
    return a.val>b.val;
}
int main()
{
    int m,n;
    while(cin>>m>>n)
    {
        if(m==-1&&n==-1)
            break;
        double sum=0;
        for(int i=0;i<n;i++)
        {
            cin>>p[i].j>>p[i].f;
            p[i].val=p[i].j/p[i].f;
        }
        sort(p,p+n,cmp);
        int cnt=0;
        while(m>0&&cnt<n)
        {
            if(p[cnt].f<=m)
            {
                sum+=p[cnt].j;
                m-=p[cnt].f;
                cnt++;
            }
            else if(p[cnt].f>m)
            {
                sum+=m*p[cnt].val;
                m=0;
                cnt++;
            }
        }
        printf("%.3lf\n",sum);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/a17865569022/article/details/81287439