ACM1009:FatMouse' Trade

Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a%
pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning
this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 
Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative
integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 
Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the
maximum amount of JavaBeans that FatMouse can obtain.
 
Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
 
Sample Output
13.333
31.500
-----------------------------------------------------------------------------------------------------
#define _CRT_SECURE_NO_WARNINGS
#include <stdio.h>
#include <math.h>
#define SIZE 1001
int J[SIZE];
int F[SIZE];
double rate[SIZE];
int bigger(int a, double keyRate, double keyJ);
int main()
{
	int M, N;
	int i, j, tempIndex;
	double tempRate,tempJ,tempF;
	double total;
	while (scanf("%d%d", &M, &N) == 2)
	{
		total = 0;
		if (M == -1 && N == -1)
			break;
		for (i = 0; i < N; i++)
		{
			scanf("%d%d", &J[i], &F[i]);
			rate[i] = ((double)F[i] / J[i]);
		}
		//插入排序
		for (i = 1; i < N; i++)
		{
			tempRate = rate[i];
			tempJ = J[i];
			tempF = F[i];
			tempIndex = i;
			j = i - 1;
			while (j >= 0 && bigger(j, tempRate, tempJ))
			{
				rate[j + 1] = rate[j];
				J[j + 1] = J[j];
				F[j + 1] = F[j];
				j = j - 1;
			}
			rate[j + 1] = tempRate;
			J[j + 1] = tempJ;
			F[j + 1] = tempF;
		}

		for (i = 0; i < N; i++)
		{
			//判断比率为0,也就是免费送的情况
			if (M > F[i] || rate[i] <= 0.0000001)
			{
				total += J[i];
				M -= F[i];
			}
			else
			{
				total += (double)M / F[i] * J[i];
				break;
			}
		}
		printf("%0.3f\n", total);
	}
}

int bigger(int a, double keyRate, double keyJ)
{
	if (fabs(rate[a] - keyRate) <= 0.000001)
		return J[a] < keyJ;
	else
	{
		return rate[a] > keyRate;
	}
}

  

猜你喜欢

转载自www.cnblogs.com/mycodinglife/p/10525642.html