【PAT甲级】Sign In and Sign Out

Problem Description: 

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

解题思路:

水题。最早登入的人开门,最晚登出的人关门。

AC代码: 

#include <bits/stdc++.h>
using namespace std;

int main()
{
    int N;
    cin >> N;
    string start = "99:99:99",end = "00:00:00";   //开门时间start,关门时间end
    string unlock,lock;  //用来记录开门的人和关门的人的id
    while(N--)
    {
        string t1,t2,t3;  //用户名t1,登入时间t2,登出时间t3
        cin >> t1 >> t2 >> t3;
        if(t2 < start)  //最早登入的人开门
        {
            start = t2;
            unlock = t1;
        }
        if(t3 > end)   //最晚登出的人关门
        {
            end = t3;
            lock = t1;
        }
    }
    cout << unlock << " " << lock << endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_42449444/article/details/89044369