【PAT甲级】1006 Sign In and Sign Out (25 分)

Sign In and Sign Out

题目描述

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

思路

本题比较简单,只要找到合适的比较两个字符串时间的方法即可,如下:

对于时间HH:MM:SS,使用三个整数h,m,s分别存储时分秒,然后计算t=10000h+100m+s,比较两个整数的t的大小就可以比较出时间的先后了

另外在找谁开门谁关门使用动态处理,随时记录当前最小时间的与最大时间对应的人

代码

注意通过使用strcpy函数来对char *类型的字符串进行拷贝

#include<stdio.h>
#include<string.h>

int main()
{
    
    
    int M;//the number of the students
    scanf("%d",&M);
    int opentime=999999,closetime=0;//record current min opentime and maxtime
    char unlockedp[16],lockedp[16],temp[16];
    for(int i=0;i<M;i++)
    {
    
    
        int h1,m1,s1,h2,m2,s2,t1,t2;
        scanf("%s %d:%d:%d %d:%d:%d",temp,&h1,&m1,&s1,&h2,&m2,&s2);
        t1=h1*10000+m1*100+s1;
        t2=h2*10000+m2*100+s2;
        if(t1<opentime)
        {
    
    
            opentime=t1;
            strcpy(unlockedp,temp);
        }
        if(t2>closetime)
        {
    
    
            closetime=t2;
            strcpy(lockedp,temp);
        }
    }
    printf("%s %s\n",unlockedp,lockedp);
    return 0;
}

另外发现,使用scanf读取字符串的时候,既可以写成scanf("%s",string),也可以写成scanf("%s",&string)

git仓库:Sign In and Sign Out

猜你喜欢

转载自blog.csdn.net/qq_35779286/article/details/95374917
今日推荐