PAT 1006 Sign In and Sign Out

At the beginning of every day, the first person who signs in thecomputer room will unlock the door, and the last one who signs out willlock the door. Given the records of signing in's and out's, you aresupposed to find the ones who have unlocked and locked the door on thatday.

Input Specification:

Each input file contains one test case. Each case contains the recordsfor one day. The case starts with a positive integer M, which is thetotal number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID number is a stringwith no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons whohave unlocked and locked the door on that day. The two ID numbers mustbe separated by one space.

Note: It is guaranteed that the records are consistent. That is, thesign in time must be earlier than the sign out time for each person, andthere are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

主要的技巧是把时间换算成long long型变量比较,十分方便,前面有一题类似的

#include<cstdio>
char name[20][10010];    //二位字符数组,用于存放名字
int main() {
	int m;
	scanf("%d", &m);
	int h1, m1, s1, h2, m2, s2;
	long long early = 240000, late = 000000;        //初始值,总是反着取
	int id1, id2;
	for (int i = 0; i < m; i++) {
		scanf("%s %d:%d:%d %d:%d:%d", name[i], &h1, &m1, &s1, &h2, &m2, &s2);
		long long time1 = h1 * 10000 + m1 * 100 + s1;
		long long time2 = h2 * 10000 + m2 * 100 + s2;
		if (time1 < early) {
			early = time1;
			id1 = i;
		}
		if (time2 > late) {
			late = time2;
			id2 = i;
		}
	}
	printf("%s %s", name[id1], name[id2]);
	return 0;
}
晴神代码,时间比较的最基本的方式
#include<cstdio>
struct person {
	char name[20];
	int h, m, s;
}temp, ans1, ans2;

bool greater(person a, person b) {        //这里return的是大于小于,不是差值
	if (a.h != b.h) return a.h>b.h;
	else if (a.m != b.m) return a.m > b.m;
	else return a.s > b.s;
}

void init() {
	ans1.h = 24, ans1.m = 60, ans1.s = 60;
	ans2.h = 00, ans2.m = 00, ans2.s = 00;
}

int main() {
	int m;
	scanf("%d", &m);
	init();
	for (int i = 0; i < m; i++) {        //很巧妙的点在于,用一个temp.h/m/s输入两组时间
		scanf("%s %d:%d:%d", temp.name, &temp.h, &temp.m, &temp.s);
		if (!greater(temp, ans1)) ans1 = temp;
		scanf("%d:%d:%d", &temp.h, &temp.m, &temp.s);
		if (greater(temp, ans2)) ans2 = temp;
	}
	printf("%s %s", ans1.name, ans2.name);
	return 0;
}


猜你喜欢

转载自blog.csdn.net/joah_ge/article/details/80548190