PTA 甲级1006 Sign In and Sign Out

PTA 甲级1006 Sign In and Sign Out (25分)

题目原文

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time 

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40    

Sample Output:

SC3021234 CS301133

生词

in time 及时

unlock 解锁

lock 上锁

关键句子

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

每天早上,第一个在电脑室签名的人会打开门,最后一个在电脑室签名的人会锁上门。根据签到记录和签到记录,你应该找到当天开门和锁门的人。

注意点

① 给的使用手机的时间可能不正确,就是使用之前的时间在使用完成的时间的后面,这种数据不能录入

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
struct UserCom {
    char Name[16];
    int beginy;
    int beginm;
    int begins; 
    int endy;
    int endm;
    int ends;       //定义开始和结束的时间
};
int main(void) {
    int K, t = 0, i, j;
    struct UserCom people[10000];
    int Sumbegin, Sumend, Sumname = 0, MinBegin=99999999,MaxEnd=0;
    int Minbegint,Maxendt;
    scanf("%d", &K);
    for (int i = 0; i < K; i++) {
        scanf("%s %d:%d:%d %d:%d:%d", &people[t].Name, &people[t].beginy,
            &people[t].beginm, &people[t].begins, &people[t].endy,
            &people[t].endm, &people[t].ends);
        Sumbegin = people[t].beginy * 3600 + people[t].beginm * 60 + people[t].begins;
        Sumend = people[t].endy * 3600 + people[t].endm * 60 + people[t].ends;
        if (Sumbegin > Sumend) {
            t--;
        } {
            if (Sumbegin < MinBegin) {
                MinBegin = Sumbegin;
                Minbegint = t;
            }
            if (Sumend > MaxEnd) {
                MaxEnd = Sumend;
                Maxendt = t;
            }
        }
        t++;
    }
    printf("%s %s", people[Minbegint].Name, people[Maxendt].Name);

    return 0;
}

猜你喜欢

转载自www.cnblogs.com/a-small-Trainee/p/12347958.html