PAT甲级 1006 Sign In and Sign Out

1006 Sign In and Sign Out (25)(25 分)

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

本题可主要是实现将时间字符串转为整数,再通过algorithm头文件中的sort函数对vector容器进行排序即可轻松解决,实现代码如下:

#include<iostream>
#include<string>
#include<vector>
#include<algorithm> 
using namespace std;

int time_to_int(string s);

struct sign{
	string s;
	int time;
};

bool Sign_in_sort(sign a,sign b){
	return a.time<b.time;
}

bool Sign_out_sort(sign a,sign b){
	return a.time>b.time;
}

int main(){
	int m;
	cin>>m;
	
	string ID_number[100];
	string Sign_in_time[100];
	string Sign_out_time[100];
	for(int i=0;i<m;i++){
		cin>>ID_number[i];//输入遇到空格结束 
		cin>>Sign_in_time[i];
		cin>>Sign_out_time[i];
	}

	vector<sign> Sign_in_vec;//注意区分vector和map的存储法 
	vector<sign> Sign_out_vec;
	
	for(int i=0;i<m;i++){
		Sign_in_vec.push_back( sign{ID_number[i], time_to_int(Sign_in_time[i]) });
		Sign_out_vec.push_back( sign{ID_number[i], time_to_int(Sign_out_time[i])} );
	}
	
	sort( Sign_in_vec.begin(),Sign_in_vec.end(),Sign_in_sort);
	sort( Sign_out_vec.begin(),Sign_out_vec.end(),Sign_out_sort);
	
	/*
	vector<sign>::iterator it;
	it = Sign_in_vec.begin();
	cout<<it->s<<" ";
	it = Sign_out_vec.begin();
	cout<<it->s;
	*/
	
	cout<<Sign_in_vec[0].s<<" "<<Sign_out_vec[0].s;
	
	return 0;
}

int time_to_int(string s){//时间转int 
	int num = 0;
	int a;
	for(int i=0;i<s.size();i++){
		if(s[i] == ':')
			continue;
		else{
			a = s[i] - '0';
			num += a;
			if(i != s.size()-1)
				num*=10;
		} 	
	}	
	
	return num;
}

猜你喜欢

转载自blog.csdn.net/qq_29762941/article/details/80957179