PAT 1006 Sign In and Sign Out (25 分)

1006 Sign In and Sign Out (25 分)

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.
Input Specification:
Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:
ID_number Sign_in_time Sign_out_time
where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.
Output Specification:
For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.
Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.
Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133




解析

这类题是有套路的。在PAT-B里也有一道类似的人口普查
如果是要比较出生日期,或者是时间。可以把它们化为下面的形式:

1989/03/19   ->  19890319*10000+月*100+日 
13:30:18     ->   1333018
小时*10000+分钟*100+秒

在我的这篇blog算法笔记:也就记录了这类方法。感兴趣的可以去看看。
Code:

#include<cstdio>
#include<iostream>
#include<vector>
#include<string>
#include<algorithm>
using namespace std;
int main()
{
    int N, hour, min, second;
    cin >> N;
    vector<string> name(N);
    vector<int> time_in(N), time_out(N);
    for (int i = 0; i < N; i++) {
        cin >> name[i];
        scanf("%d:%d:%d", &hour, &min, &second);
        time_in[i] = hour * 10000 + min * 100 + second;
        scanf("%d:%d:%d", &hour, &min, &second);
        time_out[i] = hour * 10000 + min * 100 + second;
    }
    cout << name[min_element(time_in.cbegin(),time_in.cend())-time_in.cbegin()]<<" ";
    cout << name[max_element(time_out.cbegin(),time_out.cend())-time_out.cbegin()];
}

猜你喜欢

转载自blog.csdn.net/weixin_41256413/article/details/82732031