1006 Sign In and Sign Out

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time
where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:

SC3021234 CS301133

题目大意:

给定id,sign in,sign out,要求找出最早到和最后离开的id。

分析:1、签到的时间转换成以秒为单位的时刻。 2、 输入时使用格式化的输入。

参考代码:

#include<iostream>
#include<cstdio>
#include<climits>
#include<string>
using namespace std;
int main()
{
    int n, min = INT_MAX, max = INT_MIN;
    int h1, m1, s1, h2, m2, s2;
    string id1,id2,id;
    cin >> n;

    for (int i = 1; i <= n; i++)
    {
        cin >> id;
        scanf_s("%d:%d:%d %d:%d:%d", &h1, &m1, &s1, &h2, &m2, &s2);
        int t1 = h1 * 3600 + m1 * 60 + s1;
        int t2 = h2 * 3600 + m2 * 60 + s2;
        if (t1 < min)
        {
            min = t1;
            id1 = id;
        }
        if (t2 > max)
        {
            max = t2;
            id2 = id;
        }
    }
    cout << id1 << " " << id2;

    return 0;
}

猜你喜欢

转载自blog.csdn.net/ssf_cxdm/article/details/81407306