Sign In and Sign Out (25)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_27901091/article/details/79111218

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time
where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:
SC3021234 CS301133

除了把时间一一读出来,可以用字符串比较的方法,简单得多。

/*进行M次循环。设置开门时间char t_open[] = 235959,关门时间char t_close[] = 000000。开门人char id_open[16],关门人id_close[16]。 
1.读入身份号码,上班时间和下班时间。 
2.使用strcmp将上班时间与t_open进行比较,如果上班时间小于t_open,那么strcpy(t_open,上班时间)。strcpy(id_open, id)。 
3.使用strcmp将下班时间与t_close进行比较,如果下班时间大于t_close,那么strcpy(t_close, 下班时间)。strcpy(id_close, id)。*/
#include <iostream>
#include <cstdio>
#include <cstring>

int main(void)
{
    setvbuf(stdin, new char[1 << 20], _IOFBF, 1 << 20);
    setvbuf(stdout, new char[1 << 20], _IOFBF, 1 << 20); //这两句注释了之后,就需要crtl+z来结束,有待研究此函数
    int m;
    scanf("%d", &m);
    char id_open[16], id_close[16], t_open[] = "23:59:59", t_close[] = "00:00:00";
    char id[16], arrive[9], depart[9];
    for (int i = 0; i < m; i++) {
        scanf("%s %s %s", id, arrive, depart);
        if (strcmp(t_open, arrive) > 0) {
            strcpy(id_open, id);
            strcpy(t_open, arrive);
        }
        if (strcmp(t_close, depart) < 0) {
            strcpy(id_close, id);
            strcpy(t_close, depart);
        }
    }
    printf("%s %s\n", id_open, id_close);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_27901091/article/details/79111218