PAT (Advanced Level) 1006 Sign In and Sign Out

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

AC代码:

#include <iostream>
#include <string> 
using namespace std;
int main(){
	int M;
	cin >> M;//输入考勤的人数
	 string idNumber;
	 string signInTime;//早上签到时间 
	 string signOutTime;//晚上离开时间
	 string firstId;//用来存储最早签到的人的Id 
	 string lastId;//用来储存最晚离开的人的Id 
	 string minInTime = "23:59:59";
	 string maxOutTime = "00:00:00";
	 for(int i = 0; i < M; i++) {
	 	cin >> idNumber >> signInTime >> signOutTime;
		//挨个比较signInTime和minInTime字符串的大小 
		if(signInTime < minInTime){
			minInTime = signInTime;
			firstId = idNumber; 
		}
		if(signOutTime > maxOutTime ) {
			maxOutTime = signOutTime;
			lastId = idNumber;
		}
	 }
	 cout << firstId << " " << lastId;
	return 0;
}

结果:

 

 分析思路:本题的要求就是第一行先输入签到的总人数,然后依次输入每个人信息:id ,早上签到时间,晚上离开时间

比较几个人的早上签到时间和晚上离开时间,找出最早签到的人和最晚离开的人,分别输出他们的id中间用一个空格隔开。

猜你喜欢

转载自blog.csdn.net/wangjian530/article/details/83214816