1006.Sign in and Sign out(25)—PAT 甲级

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

题目大意:在一堆开门关门的员工中,分别找到最早开门和最晚关门的员工号.
分析:利用c++string类型用字典序进行比较的特性直接比较开门时间和关门时间,temp_unlock和temp_lock分别是比较开门时间和关门时间的临时变量,first_unlock和last_lock分别用来记录最早开门和最晚开门的员工号。

#include <iostream>
using namespace std;
int main() {
    string first_unlock,final_lock;
    int m;
    scanf("%d",&m);
    string id_number,unlock,lock;
    string temp_unlock="9",temp_lock="0";
    for(int i=0;i<m;i++)
    {
        cin>>id_number>>unlock>>lock;
        if(unlock<temp_unlock){
            temp_unlock=unlock;
            first_unlock=id_number;
        }
        if(lock>temp_lock){
            temp_lock=lock;
            final_lock=id_number;
        }
    }
    cout<<first_unlock<<" "<<final_lock<<endl;
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/Endlessp162096/p/8971944.html