PAT Sign In and Sign Out[非常简单]

1006 Sign In and Sign Out (25)(25 分)

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

#include <iostream>
#include <cstring>
#include <cstdio>
#include<map>
#include<stack>
using namespace std;
struct person{
    string id;
    string start;
    string ends;
}p[1001];
int main()
{

    freopen("1.txt","r",stdin);
    int n;
    cin>>n;
    for(int i=0;i<n;i++){
       cin>>p[i].id>>p[i].start>>p[i].ends;
    }
    int s=0,e=0;
    string ss=p[0].start,se=p[0].ends;
    for(int i=1;i<n;i++){
        if(p[i].start<ss){
            ss=p[i].start;
            s=i;
        }
        if(p[i].ends>se){//这里se写成了ss导致提交了两次都不是满分。
            se=p[i].ends;
            e=i;
        }
    }
    cout<<p[s].id<<" "<<p[e].id;
    return 0;
}

//这道题能不能再简单易一点?就是利用string 来比较。给出了id 起始时间 终止时间。找出最早开始时间和最晚结束时间。那么因为时间格式都一样,不就直接比较就可以了?直接得出设置最先开始的,谁是最后结束的,输出id即可。

猜你喜欢

转载自www.cnblogs.com/BlueBlueSea/p/9335341.html