POJ 2533(最大递增子序列)

Description

A numeric sequence of ai is ordered if a1 < a2 < … < aN. Let the subsequence of the given numeric sequence (a1, a2, …, aN) be any sequence (ai1, ai2, …, aiK), where 1 <= i1 < i2 < … < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

代码+题解

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int N;
int arr[1005],dp[1005];
int mmp()
{
    int ans=1;
    for(int i=1;i<=N;i++)
    {
        dp[i]=1;
        for(int j=1;j<i;j++)
        {
            if(arr[j]<arr[i])            //每进行一次循环,dp[i]都会变为当前最大的递增子序列。
                dp[i]=max(dp[j]+1,dp[i]);
        }
        ans=max(ans,dp[i]);          //找出N组递增子序列中最大的即可。
    }
    return ans;
}
int main()
{
    scanf("%d",&N);
    for(int i=1;i<=N;i++)
        scanf("%d",&arr[i]);
    int ans=mmp();
    printf("%d\n",ans);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43105110/article/details/88088775