最长上升子序列 POJ 2533

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/tju_peter/article/details/52160958
Longest Ordered Subsequence
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 47004   Accepted: 20885

Description

A numeric sequence of  ai is ordered if  a1 <  a2 < ... <  aN. Let the subsequence of the given numeric sequence ( a1a2, ...,  aN) be any sequence ( ai1ai2, ...,  aiK), where 1 <=  i1 <  i2 < ... <  iK <=  N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

Source

Northeastern Europe 2002, Far-Eastern Subregion

最长上升子序列:
O(n2)复杂度
dp[i]表示以第i个未知的数作为子序列中最后一个元素时,能够构成的子序列的最大长度。
转移方程:dp[i]=max9dp[i],dp[j]+1)
#include <iostream>

using namespace std;

int main()
{
    int n;
    cin>>n;
    int i,j,a[n],b[n],m=0;
    for(i=0;i<n;i++)
        cin>>a[i];
    b[0]=1;
    for(i=1;i<n;i++)
    {
        b[i]=1;
        for(j=0;j<i;j++)
        {
            if(a[i]>a[j] && b[j]+1>b[i])
                b[i]=b[j]+1;
        }
    }
    for(i=0;i<n;i++)
    {
        if(b[i]>m)
            m=b[i];
    }
    cout<<m<<endl;
    return 0;
}
O(nlogn)
利用二分去搜索,每一次去找dp[ ]值最大的那个 最小的数 二分会降到O(nlogn)
<pre name="code" class="cpp">#include <iostream>

using namespace std;

int dp[10001];
int main()
{
    int n;
    cin>>n;
    dp[0]=0;
    int tail=0,a;
    for(int i=1;i<=n;i++)
    {
        cin>>a;
        //二分
        int low=0,high=tail-1;
        while(low<=high)
        {
            int mid=(low+high)/2;
            if(dp[mid]>=a)
                high=mid-1;
            else low=mid+1;
        }
        if(low>=tail)
            tail++;
        dp[low]=a;
    }
    cout<<tail<<endl;
    return 0;
}
 
 

猜你喜欢

转载自blog.csdn.net/tju_peter/article/details/52160958