POJ 2533

版权声明:如果转载,请注明出处。 https://blog.csdn.net/S_999999/article/details/81805271

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence ( a1a2, ..., aN) be any sequence ( ai1ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8). 

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4
//求最长上升子序列
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std; 
int dp[10005];
int main(void){
	
	 int n,a[10005];
	 while(scanf("%d",&n)!=EOF){
	 	
	 	memset(dp,0,sizeof(dp));
	 	
	 	for(int i =1;i<=n;i++)
	 	    scanf("%d",&a[i]);
	 	    
	 	    dp[1] = 1;
	 	 for(int i=1;i<=n;i++){
		   
		      for(int j =1;j<i;j++)
			     if(a[i] > a[j])
				  dp[i] = max(dp[i],dp[j] +1);
		   
		     if(dp[i] == 0)
		       dp[i] = 1;
	      }
	 	 
       int maxn = -1;
	      for(int i =1;i<=n;i++)
	 	     if(dp[i] > maxn)
	 	        maxn = dp[i];
	    memset(dp,0,sizeof(dp));
	  
	 	      
	 	 	printf("%d\n",maxn);
	 	
	  }
	
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/S_999999/article/details/81805271