POJ 2533 Longest Ordered Subsequence (最长上升子序列)

题目描述:

  

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence ( a1, a2, ..., aN) be any sequence ( ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

题目理解:给你一串数,找出其中单调有序最长的子序列(两个数之间不一定相邻)例如案例中输入 1 7 3 5 9 4 8

输出 4 ,这里的 4 由序列1 3 5 8或1 4 5 8构成,不论是哪个,长度都是4

代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn=10010;
int dp[maxn];
int  a[maxn];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
       for(int i=0;i<n;i++)
       {
           scanf("%d",&a[i]);
           dp[i]=1;
          // memset(dp,1,sizeof(dp));
       }
        int maxn=0;
        for(int i=0;i<n;i++)
        {
           for(int j=0;j<=i-1;j++)
            if(a[j]<a[i]&&dp[i]<dp[j]+1)//dp[i]<dp[j]+1这个条件不可以忽略
             {
                 dp[i]=dp[j]+1;
             }
        }
        for(int i=0;i<n;i++)
            maxn=max(dp[i],maxn);
       cout<<maxn<<endl;
    }
    return 0;
}

/*上方的       if(a[j]<a[i]&&dp[i]<dp[j]+1)
             {
                 dp[i]=dp[j]+1;
             }
还可以改为if(a[j]<a[i])
           dp[i]=max(dp[i],dp[j]+1);
*/

下面是对上方代码的运行过程分析 

1 7 3 5 9 4 8

下方的代码分析可体现“dp[i]<dp[j]+1”的作用
a[i]=a[0]=1  a[j]=a[0]=1,但不满足“j<=i-1",故j=i=0的情况不起作用

a[i]=a[1]=7     a[j]=a[0]=1    a[i]>a[j]    dp[1]=dp[0]+1=2;

a[i]=a[2]=3     a[j]=a[0]=1    a[i]>a[j]    dp[2]=dp[0]+1=2
                a[j]=a[1]=7    a[i]<a[j]

a[i]=a[3]=5     a[j]=a[0]=1     a[i]>a[j]    dp[3]=dp[0]+1=2
                a[j]=a[1]=7     a[i]<a[j]
                a[j]=a[2]=3     a[i]>a[j]    dp[3]=dp[2]+1=3

a[i]=a[4]=9     a[j]=a[0]=1     a[i]>a[j]    dp[4]=dp[0]+1=2
                a[j]=a[1]=7     a[i]>a[j]    dp[4]=dp[1]+1=3
                a[j]=a[2]=3     a[i]>a[j]    dp[4]=dp[2]+1=3
                a[j]=a[3]=5     a[i]>a[j]    dp[4]=dp[3]+1=4

a[i]=a[5]=4     a[j]=a[0]=1     a[i]>a[j]    dp[5]=dp[0]+1=2
                a[j]=a[1]=7     a[i]<a[j]   
                a[j]=a[2]=3     a[i]>a[j]    dp[5]=dp[2]+1=3
                a[j]=a[3]=5     a[i]<a[j] 
                a[j]=a[4]=9     a[i]<a[j]     


a[i]=a[6]=8     a[j]=a[0]=1     a[i]>a[j]    dp[6]=dp[0]+1=2
                a[j]=a[1]=7     a[i]>a[j]    dp[6]=dp[1]+1=3
                a[j]=a[2]=3     a[i]>a[j]    dp[6]=dp[2]+1=3
                a[j]=a[3]=5     a[i]>a[j]    dp[6]=dp[3]+1=4
                a[j]=a[4]=9     a[i]<a[j]    
                a[j]=a[5]=5     a[i]>a[j]    dp[6]=dp[5]+1=4

                  





由上方可知,假设没有dp[i]<dp[j]+1这一条件,在每一个i值之下,每运行一次j值,dp[i]便会更新一次,然而dp[i]值会出现相同的,这个条件便是避免了再次被相同值覆盖。 

猜你喜欢

转载自blog.csdn.net/fanxingxue/article/details/82854843