POJ 2533 最大上升子序列(动态规划学习)

Longest Ordered Subsequence
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 60136   Accepted: 26932

Description

A numeric sequence of  ai is ordered if  a1 <  a2 < ... <  aN. Let the subsequence of the given numeric sequence ( a1a2, ...,  aN) be any sequence ( ai1ai2, ...,  aiK), where 1 <=  i1 <  i2 < ... <  iK <=  N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

Source

Northeastern Europe 2002, Far-Eastern Subregion

将最大上升子列长度问题,分解为以下标k结尾的最大上升子列长度

以下表k结尾的长度可能是以前一个下标i结尾的长度+1,如果找不到,那么只能1

最后求出下标k中的最大值

#include<iostream> 
#include<algorithm>
#define MAX 1010
using namespace std;
int a[MAX],maxLen[MAX];
int main()
{
	int n,i,j;
	cin>>n;
	for(i=0;i<n;i++)
	{
		cin>>a[i];
		maxLen[i] = 1;
	}
	for(i=1;i<n;i++)
	{
		for(j=0;j<i;j++)
		{
			if(a[i]>a[j])
			{
				maxLen[i]=max(maxLen[i],maxLen[j]+1);
			}
		}
	}
	cout<< * max_element(maxLen,maxLen+n)<<endl;
}


猜你喜欢

转载自blog.csdn.net/wwxy1995/article/details/80171912