poj 2533 Longest Ordered Subsequence

Longest Ordered Subsequence
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 59436   Accepted: 26637

Description

A numeric sequence of  ai is ordered if  a1 <  a2 < ... <  aN. Let the subsequence of the given numeric sequence ( a1a2, ...,  aN) be any sequence ( ai1ai2, ...,  aiK), where 1 <=  i1 <  i2 < ... <  iK <=  N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

题意:求最长上升子序列...

思路:模版题


ac代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;

int a[4007], dp[4007];
int n;

int bin(int len,int k)
{
    int l = 1, r = len;
    while(l <= r)
    {
        int mid = (l+r)/2;
        if(k > dp[mid])
            l = mid+1;
        else
            r = mid-1;
    }
    return l;
}

int LIS(int *a)
{
    int i,j,ans=1;
    dp[1] = a[1];
    for(i = 2; i <= n; i++)
    {
        if(a[i] < dp[1])//如果比最小的还小 (纯升,不包含等于情况)
            j = 1;
        else if(a[i] > dp[ans])//如果比最大的还大
            j = ++ans;
        else
            j = bin(ans,a[i]);
        dp[j] = a[i];
    }
    return ans;
}

int LDS(float *a)
{

    int i,j,ans = 1;
    dp[1] = a[1];
    for(i = 1; i <= n; i++)
    {
        if(a[i] > dp[1])//如果比最大的还大
            j = 1;
        else if(a[i] < dp[ans])//如果比最小的还小(纯降 不包含等于情况)
            j = ++ans;
        else
            j = bin(ans,a[i]);
        dp[j] = a[i];
    }
    return ans;
}

int main()
{
    scanf("%d",&n);
    for(int i = 1; i <= n; i++)
        scanf("%d",&a[i]);

    int answer = LIS(a);
    printf("%d\n",answer);

    return 0;
}



猜你喜欢

转载自blog.csdn.net/ac_blood/article/details/79869928