FatMouse' Trade (九度教程第 21 题)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_37053885/article/details/88137386

FatMouse' Trade (九度教程第 21 题)

时间限制:1 秒 内存限制:128 兆 特殊判题:否

1.题目描述:

题目描述:
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
输入:
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.
输出:
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
样例输入:
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
样例输出:
13.333
31.500

2.基本思路

该题类似于背包问题中可以只装一个物品的一部分的情况,利用贪心策略。首先定义一个结构体room用于存取其对应的 J J F F ,然后对结构体数据利用 J F \frac{J}{F} 的大小(可以理解为性价比),对结构体数组进行降序排序,然后先取性价比最高的物品,直到背包不能再装下一个物品的时候只装一部分。

3.代码实现

#include <iostream>
#include <algorithm>
#define N 1001
using namespace std;

struct room{
    int j;
    int f;
}buf[N];

bool cmp(room a,room b){

     return (double)a.j/(double)a.f>(double)b.j/(double)b.f;

}
int main()
{
    int m,n;
    double ans=0;
    while(scanf("%d%d",&m,&n)!=EOF){
        if(m==-1&&n==-1)break;
        ans=0;
        for(int i=0;i<n;i++){
            scanf("%d%d",&buf[i].j,&buf[i].f);
        }
        sort(buf,buf+n,cmp);
        int idx=0;
        while(m!=0||idx<n){//但还有钱剩余,或者物品还没取完的时候
            if(m>=buf[idx].f){
                ans+=buf[idx].j;
                m-=buf[idx].f;
            }
            else{
                ans+=(double)buf[idx].j*((double)m/(double)buf[idx].f);
                m=0;
            }
            idx++;
        }
        printf("%.3f\n",ans);
    }
    return 0;
}
/*
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
*/

猜你喜欢

转载自blog.csdn.net/qq_37053885/article/details/88137386