POJ 1458 Common Subsequence(最长公共子序列LCS)

版权声明:如果转载,请注明出处。 https://blog.csdn.net/S_999999/article/details/81809033

Common Subsequence

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 61754   Accepted: 25871

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0
// 求最长 公共子序列
//  DP[i][j]  表示  a 字符串的  前i个字符  与 b字符串 的 前j 个 字符  公共字符最大数量(记清楚)
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char a[1009],b[1009];
int dp[1009][1009];
int main(void){
	 
	  
	 
	 while(~scanf("%s%s",a,b)){
	 	
	 	memset(dp,0,sizeof(dp));
	 	for(int i = 0;i<strlen(a);i++)
	 	    for(int j =0;j<strlen(b);j++)
	 	        if(a[i] == b[j])
	 	             dp[i+1][j+1] = dp[i][j] + 1 ;
	 	        else dp[i+1][j+1] = max(dp[i][j+1],dp[i+1][j]);
	 	
	 	printf("%d\n",dp[strlen(a)][strlen(b)]);
	 }
	     
		 	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/S_999999/article/details/81809033