Longest Ordered Subsequence (最长递增子序列的长度)(序列型dp)

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence ( a1a2, ..., aN) be any sequence ( ai1ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8). 

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

总结:  赋初值的时候用memset(),TM结果出乱码,看来memset对于大点的数还是不要用,避免出错

代码:

#include<iostream>
using namespace std;
int main()
{
	int n;
	int a[1005],dp[1005];
	cin>>n;
	for(int i=0;i<n;i++)
	    cin>>a[i];
	for(int i=0;i<n;i++)
	    dp[i]=1;
	for(int i=0;i<n;i++)
	{
		for(int j=0;j<i;j++)
	    {
	   	  if(a[i]>a[j]&&dp[j]+1>dp[i])
	   	    dp[i]=dp[j]+1;
	    }
	}
	int maxx=0;
	for(int i=0;i<n;i++)
	   maxx=max(maxx,dp[i]);
	cout<<maxx<<endl;
 } 

猜你喜欢

转载自blog.csdn.net/daoshen1314/article/details/84797383
今日推荐