【DP】Longest Ordered Subsequence

描述

A numeric sequence of ai is ordered if a1 < a2 < … < aN. Let the subsequence of the given numeric sequence (a1, a2, …, aN) be any sequence (ai1, ai2, …, aiK), where 1 <= i1 < i2 < … < iK <= N. For example, the sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e.g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences of this sequence are of length 4, e.g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

输入

The first line of input contains the length of sequence N (1 <= N <= 1000). The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces.

输出

Output must contain a single integer - the length of the longest ordered subsequence of the given sequence.

样例输入

1

7
1 7 3 5 9 4 8

样例输出

4

提示

This problem contains multiple test cases!
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

分析:
注意输出格式。
DP方程
dp[i]=(1,dp[j]+1);(num[i]>num[j]&&i>j)

代码:
#include<bits/stdc++.h>
using namespace std;
int main()
{
int ans,T,n,a[1001],dp[1001];
cin>>T;
while(T–)
{
cin>>n;
memset(dp,0,sizeof(dp));
ans=0;
for (int i=0;i<n;i++)
cin>>a[i];
for (int i=0;i<n;i++)
{
dp[i]=1;
for (int j=0;j<i;j++)
{
if (a[j]<a[i])
{
dp[i]=max(dp[i],dp[j]+1);
}
}
ans=max(ans,dp[i]);
}
cout<<ans<<endl;
if (T) cout<<endl;
}
return 0;
}

发布了40 篇原创文章 · 获赞 0 · 访问量 672

猜你喜欢

转载自blog.csdn.net/Skynamer/article/details/103652262