POJ - 2533 - Longest Ordered Subsequence (dp & 最长子串)

POJ - 2533 - Longest Ordered Subsequence

POJ - 2533 - Longest Ordered Subsequence
A numeric sequence of ai is ordered if a1 < a2 < … < aN. Let the subsequence of the given numeric sequence ( a1, a2, …, aN) be any sequence ( ai1, ai2, …, aiK), where 1 <= i1 < i2 < … < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input
The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output
Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input
7
1 7 3 5 9 4 8
Sample Output
4

题目链接
也是个板子题,求最长上升子序列的长度。dp用于记录该字符所能构成的最长字符的长度,感觉跟这个题目是一样的,每次便利的时候,都从前面所有的dp数组里面找长度最长的,然后再此基础上加一就行了。

AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 1e3 + 5;
int a[maxn], dp[maxn];

int main()
{
    int n, maxx = -1;
    while(~scanf("%d", &n))
    {
        memset(dp, 0, sizeof(dp));
        for(int i = 1; i <= n; i++) scanf("%d", &a[i]);
        for(int i = 1; i <= n; i++)
        {
            dp[i] = 1;
            for(int j = 1; j < i; j++)
            {
               if(a[i] > a[j] && dp[j] + 1 > dp[i])    dp[i] = dp[j] + 1;
            }
        }
        sort(dp + 1, dp + n + 1);
        printf("%d\n", dp[n]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_40788897/article/details/81745605
今日推荐