Longest Ordered Subsequence(最长上升子序列)

  A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence ( a1a2, ..., aN) be any sequence ( ai1ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8). 

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

注意:==1.dp[i]存放的是以a[i]为末尾的最长上升子序列的长度==

          == 2.不要忘了将dp数组初始化为1,因为一个数字就是一个子序列,dp值为1,一开始每个数字的dp值都为1==

#include<iostream>
#include<cstring>
#include<cmath>
using namespace std;
int dp[1005],a[1005];
int n;
int main() {
	int maxx=0;
	scanf("%d",&n);
	for(int i=1; i<=n; i++) {
		scanf("%d",&a[i]);
		dp[i]=1;
	}
	for(int i=2; i<=n; i++){
		for(int j=1; j<i; j++) {
			if(a[i]>a[j])
				dp[i]=max(dp[i],dp[j]+1);
		}
	}
	for(int i=1; i<=n; i++)
		maxx=max(maxx,dp[i]);
	printf("%d\n",maxx);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41938789/article/details/84798038