最长公共子序列模板 Longest Ordered Subsequence

题目  :

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence ( a1, a2, ..., aN) be any sequence ( ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input
The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output
Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input
7
1 7 3 5 9 4 8
Sample Output
4

大意:就是让你找单点递增最长子序列,输出最长的那个数,这也算是一个模板题了吧,,。

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int main(){
	int a[1005] , d[1005];
	int n , ans = 0 , t ;
	cin>>n;
	for(int i = 1 ; i <= n ; i ++){
		cin>>a[i];
	}
	int i , len , pos , j;
	d[1] = a[1] ;
	len = 1 ;
	for(int i = 2 ; i <= n ; i ++){
		if(a[i] > d[len]){
			d[++len] = a[i];
		}
		else{
			j = lower_bound(d+1,d+len+1,a[i])-d;
			d[j] = a[i];
		}
	}
	cout<<len<<endl;
	return 0 ;
}

猜你喜欢

转载自blog.csdn.net/yuewenyao/article/details/79993590
今日推荐