Longest Ordered Subsequence(dp)

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence ( a1, a2, ..., aN) be any sequence ( ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

题意:求最长上升子序列
dp[i] 是表示第i个数字和它之前a[0]到a[i-1]的数字构成的最大上升序列的长度值。
求出dp数组所有的值,用一个for循环找出最大值,就是题目要求的最长上升子序列的值。

#include<stdio.h>
#include<string.h>

int a[1010],dp[1010];
int main()
{
    int i,j,n,ans,temp;
    while(scanf("%d",&n) != EOF)
    {
        memset(a,0,sizeof(a));
        memset(dp,0,sizeof(dp));
        dp[1] = 1;
		ans = 1;
        for(i = 1; i <= n; i ++)
            scanf("%d",&a[i]);
      
        for(j = 2; j <= n; j ++) //二重循环求dp数组。 
        {
            temp = 0;
            for(i = 1; i < j; i ++)        
            {
                if(a[i] < a[j])   //  找出在这个数之前比它小的数字。
                {
                    if(temp < dp[i])  
                        temp = dp[i]; // 找出比这个数字小的数字里的最大的dp值。就是长度值。
                }
            }
            dp[j] = temp + 1;    //加一就是这个数字的dp值。
        }
        
        for(i = 1; i < n; i ++)
        {
            if(dp[i+1] > ans)
            ans = dp[i+1];
        }
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/queen00000/article/details/81331875