POJ - 2533 Longest Ordered Subsequence(最长上升子序列问题+二分优化)

题目链接https://vjudge.net/contest/347032#problem/G
Longest Ordered Subsequence
Time Limit: 2000MS Memory Limit: 65536K
Description
A numeric sequence of ai is ordered if a1 < a2 < … < aN. Let the subsequence of the given numeric sequence (a1, a2, …, aN) be any sequence (ai1, ai2, …, aiK), where 1 <= i1 < i2 < … < iK <= N.
For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).
Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input
The first line of input file contains the length of sequence N. The second line contains the elements of sequence N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output
Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

分析
最长上升子序列问题,可以用dp有效的求解。
定义:dp[i]:以a[i]为结尾的上升子序列的长度。
以a[i]结尾的上升子序列是:
1.只包含a[i]的子序列
2.在满足j<i并且a[j]<a[i]的以a[j]为结尾的上升子列末尾,追加a[i]后得到的子序列。
这两种关系任选其一得到如下递推式:
dp[i]=max{1,dp[j]+1|j<i且a[j]<a[i]};
代码

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=1e3+10;
int n,a[N],dp[N];
/*dp[i]表示以a[i]为结尾的最长上升子序列的长度*/
int main()
{
    memset(dp,0,sizeof(dp));
    scanf("%d",&n);
    for(int i=1; i<=n; i++)
        scanf("%d",&a[i]);
    int res=0;
    for(int i=1; i<=n; i++)
    {
        dp[i]=1;
        for(int j=1; j<i; j++)
        {
            if(a[j]<a[i])
                dp[i]=max(dp[i],dp[j]+1);
        }
        res=max(res,dp[i]);
    }
    printf("%d\n",res);
    return 0;
}

优化
以上求解我们利用dp,求取针对最末尾的元素的最长的子序列。
那么最末尾的元素较小的在之后会更加有优势
反过来,针对相同长度情况下最小的末尾元素进行求解。
dp[i]:长度为i+1的上升子序列中末尾元素的最小值(不存在的话就是INF)。
1.最开始全部的dp[i]的值都初始化为INF。
2.对于每一个a[j],如果i=0或者dp[i-1]<a[j]的话,就用dp[i]=min(dp[j],a[j])进行更新。
最终找出使得dp[i]<INF的最大的i+1就是结果
二分优化的过程:
在这里插入图片描述

代码

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int N=1e3+10;
const int INF=0x3f3f3f3f;
int n,a[N],dp[N];
int main()
{
    scanf("%d",&n);
    fill(dp,dp+n,INF);
    for(int i=0; i<n; i++)
        scanf("%d",&a[i]);
    for(int i=0; i<n; i++)
    {
        *lower_bound(dp,dp+n,a[i])=a[i];
    }
    printf("%d\n",lower_bound(dp,dp+n,INF)-dp);/*dp数组中第一个>=INF的位置*/
    return 0;
}

在这里插入图片描述
良好的习惯是成功的保障。
凡是都有因果。

发布了165 篇原创文章 · 获赞 6 · 访问量 5044

猜你喜欢

转载自blog.csdn.net/lylzsx20172018/article/details/103703982