Hdu 1728 逃离迷宫

逃离迷宫

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 26874    Accepted Submission(s): 6550

Problem Description

  给定一个m × n (m行, n列)的迷宫,迷宫中有两个位置,gloria想从迷宫的一个位置走到另外一个位置,当然迷宫中有些地方是空地,gloria可以穿越,有些地方是障碍,她必须绕行,从迷宫的一个位置,只能走到与它相邻的4个位置中,当然在行走过程中,gloria不能走到迷宫外面去。令人头痛的是,gloria是个没什么方向感的人,因此,她在行走过程中,不能转太多弯了,否则她会晕倒的。我们假定给定的两个位置都是空地,初始时,gloria所面向的方向未定,她可以选择4个方向的任何一个出发,而不算成一次转弯。gloria能从一个位置走到另外一个位置吗?

Input

  第1行为一个整数t (1 ≤ t ≤ 100),表示测试数据的个数,接下来为t组测试数据,每组测试数据中,
  第1行为两个整数m, n (1 ≤ m, n ≤ 100),分别表示迷宫的行数和列数,接下来m行,每行包括n个字符,其中字符'.'表示该位置为空地,字符'*'表示该位置为障碍,输入数据中只有这两种字符,每组测试数据的最后一行为5个整数k, x1, y1, x2, y2 (1 ≤ k ≤ 10, 1 ≤ x1, x2 ≤ n, 1 ≤ y1, y2 ≤ m),其中k表示gloria最多能转的弯数,(x1, y1), (x2, y2)表示两个位置,其中x1x2对应列,y1, y2对应行。

Output

  每组测试数据对应为一行,若gloria能从一个位置走到另外一个位置,输出“yes”,否则输出“no”。

Sample Input

2

5 5

...**

*.**.

.....

.....

*....

1 1 1 1 3

5 5

...**

*.**.

.....

.....

*....

2 1 1 1 3

Sample Output

no

yes

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <queue>
using namespace std;
const int SIZE = 110;
const int dx[] = {1, -1, 0, 0};
const int dy[] = {0, 0, -1, 1};

char maze[SIZE][SIZE];
int v[SIZE][SIZE];
int ex, ey, bx, by;
int m, n, limit;

struct node
{
    int x, y;
    int step;
};

queue<node> Q;

int check(int x, int y)
{
    if(x >= 1 && y >= 1 && x <= m && y <= n && maze[x][y] != '*')
        return 1;
    return 0;
}


void init()
{
    memset(v, 0, sizeof(v));
    memset(maze, 0, sizeof(maze));
    while(!Q.empty()) Q.pop();
}


 void bfs(int bx, int by)
{
    if(bx == ex && by == ey)
    {
        printf("yes\n");
        return ;
    }
    v[bx][by] = 1;
    node in, out;
    in.x = bx; in.y = by;
    in.step = -1;
    Q.push(in);
    while(!Q.empty())
    {
        out = Q.front();
        Q.pop();
        int x = out.x;
        int y = out.y;
        for(int i = 0; i < 4; i++)
        {
            int xx = x + dx[i];
            int yy = y + dy[i];
            while(check(xx, yy))
            {
                if(!v[xx][yy])
                {
                    in.x = xx;
                    in.y = yy;
                    in.step = out.step+1;
                    Q.push(in);
                    v[xx][yy] = 1;
                    if(xx == ex && yy == ey && in.step <= limit)  //注意,判断条件是在这里。                     {
                        printf("yes\n");
                        return ;
                    }
                }
                xx += dx[i];
                yy += dy[i];
            }
        }
    }
    printf("no\n");
    return; 
}



int main()
{
    int T;
    scanf("%d", &T);
    while(T--)
    {
        init();
        scanf("%d%d", &m, &n);
        for(int i = 1; i <= m; i++)     
        {
            for(int j = 1; j <= n; j++) //从1开始的,不能用字符串输入。             {
                scanf(" %c", &maze[i][j]);
            }        
        }
        scanf("%d%d%d%d%d", &limit, &by, &bx, &ey, &ex);
        bfs(bx, by);
    }
    return 0;
}

  

猜你喜欢

转载自blog.csdn.net/zhangliu463884153/article/details/80029397