hdu 1728 逃离迷宫 bfs

 给定一个m × n (m行, n列)的迷宫,迷宫中有两个位置,gloria想从迷宫的一个位置走到另外一个位置,当然迷宫中有些地方是空地,gloria可以穿越,有些地方是障碍,她必须绕行,从迷宫的一个位置,只能走到与它相邻的4个位置中,当然在行走过程中,gloria不能走到迷宫外面去。令人头痛的是,gloria是个没什么方向感的人,因此,她在行走过程中,不能转太多弯了,否则她会晕倒的。我们假定给定的两个位置都是空地,初始时,gloria所面向的方向未定,她可以选择4个方向的任何一个出发,而不算成一次转弯。gloria能从一个位置走到另外一个位置吗?

Input

  第1行为一个整数t (1 ≤ t ≤ 100),表示测试数据的个数,接下来为t组测试数据,每组测试数据中,
  第1行为两个整数m, n (1 ≤ m, n ≤ 100),分别表示迷宫的行数和列数,接下来m行,每行包括n个字符,其中字符'.'表示该位置为空地,字符'*'表示该位置为障碍,输入数据中只有这两种字符,每组测试数据的最后一行为5个整数k, x 1, y 1, x 2, y 2 (1 ≤ k ≤ 10, 1 ≤ x 1, x 2 ≤ n, 1 ≤ y 1, y 2 ≤ m),其中k表示gloria最多能转的弯数,(x 1, y 1), (x 2, y 2)表示两个位置,其中x 1,x 2对应列,y 1, y 2对应行。

Output

  每组测试数据对应为一行,若gloria能从一个位置走到另外一个位置,输出“yes”,否则输出“no”。

Sample Input

2
5 5
...**
*.**.
.....
.....
*....
1 1 1 1 3
5 5
...**
*.**.
.....
.....
*....
2 1 1 1 3

Sample Output

no
yes

就是寻找最短的路径,只是将走一步变成了走一行或者走一列(前提是没遇到障碍物)。。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <queue>
using namespace std;
int t;
char mapp[105][105];
int is[105][105];
int n,m;
int k,x1,y1,x2,y2;
int loc[4][2]={{0,-1},{0,1},{-1,0},{1,0}};
struct peo
{
    int locx,locy;
    int step;
};
int bfs ()
{
    if(x1==x2&&y1==y2)
        return 1;
    queue<peo>q;
    peo now,next;
    now.locx=x1; now.locy=y1; now.step=0;
    is[x1][y1]=1;
    q.push(now);
    while (!q.empty())
    {
        now=q.front();
        q.pop();
        for (int i=0;i<4;i++)
        {
            next.step=now.step+1;
            next.locx=now.locx+loc[i][0];
            next.locy=now.locy+loc[i][1];
            while (1)
            {
                 if(next.locx>=1&&next.locx<=m&&next.locy>=1&&next.locy<=n&&mapp[next.locx][next.locy]=='.')
                {
                    if(next.locx==x2&&next.locy==y2&&next.step<=k+1)
                    {
                      //printf("::: %d  %d %d\n",next.step,next.locx,next.locy);
                       return 1;
                    }
                    if(!is[next.locx][next.locy])
                    {
                        q.push(next);
                        is[next.locx][next.locy]=1;
                    }

                 next.locx+=loc[i][0];
                 next.locy+=loc[i][1];
                }
                else
                    break;
            }

        }
    }
      return 0;

}
int main()
{
    int t;
    scanf("%d",&t);
    while (t--)
    {
        memset (is,0,sizeof(is));
        scanf("%d%d",&m,&n);
        for (int i=1;i<=m;i++)
            for (int j=1;j<=n;j++)
                cin>>mapp[i][j];
        scanf("%d%d%d%d%d",&k,&y1,&x1,&y2,&x2);
        if(bfs ())
            printf("yes\n");
        else
            printf("no\n");

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41410799/article/details/81347706