POJ 2392 多重背包

The cows are going to space! They plan to achieve orbit by building a sort of space elevator: a giant tower of blocks. They have K (1 <= K <= 400) different types of blocks with which to build the tower. Each block of type i has height h_i (1 <= h_i <= 100) and is available in quantity c_i (1 <= c_i <= 10). Due to possible damage caused by cosmic rays, no part of a block of type i can exceed a maximum altitude a_i (1 <= a_i <= 40000). 

Help the cows build the tallest space elevator possible by stacking blocks on top of each other according to the rules.

Input

* Line 1: A single integer, K 

* Lines 2..K+1: Each line contains three space-separated integers: h_i, a_i, and c_i. Line i+1 describes block type i.

Output

* Line 1: A single integer H, the maximum height of a tower that can be built

Sample Input

3
7 40 3
5 23 8
2 52 6

Sample Output

48

Hint

OUTPUT DETAILS: 

From the bottom: 3 blocks of type 2, below 3 of type 1, below 6 of type 3. Stacking 4 blocks of type 2 and 3 of type 1 is not legal, since the top of the last type 1 block would exceed height 40.

题意:有n种石头,每个石头的高度hi,允许用的最高高度为ai,数量为ci,求能组合的最高高度。

思路:先给这些石头排个序,最高高度小的在前面,这样才能使得高度最大,然后再按多重背包来做,这样就可以了。

#include<iostream>
#include<cmath>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
struct node{
    int ci,hi,ai;
    bool operator < (const node &a)const
    {
        return ai<a.ai;
    }
}num[500];
bool cmp(node a,node b)
{
    return a.ai<b.ai;
}
int f[40010];
int dp[40010];
int main() {
	int n;
//	memset(dp,-1,sizeof dp);
	scanf("%d",&n);
	for(int i=0;i<n;i++)
        scanf("%d%d%d",&num[i].hi,&num[i].ai,&num[i].ci);
        sort(num,num+n);
        dp[0]=1;
    for(int i=0;i<n;i++)
    {
        for(int j=1;j<=num[i].ci;j++)
        {
            for(int k=num[i].ai;k>=num[i].hi;k--)
                dp[k]|=dp[k-num[i].hi];
        }
    }

    for(int i=40000;i>=0;i--)
    if(dp[i]==1){
        printf("%d\n",i);break;
    }
	return 0;
}

上面的方法类似01背包来解决 ,但两种方法都是将ai从小到大排好序,然后枚举数量来找到最优解

#include<iostream>
#include<cmath>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
struct node{
    int ci,hi,ai;
    bool operator < (const node &a)const
    {
        return ai<a.ai;
    }
}num[500];
bool cmp(node a,node b)
{
    return a.ai<b.ai;
}
int f[40010];
int dp[40010];
int main() {
	int n;
	memset(dp,-1,sizeof dp);
	scanf("%d",&n);
	for(int i=0;i<n;i++)
        scanf("%d%d%d",&num[i].hi,&num[i].ai,&num[i].ci);
        sort(num,num+n);
        dp[0]=0;
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<=num[i].ai;j++)
        {
            if(dp[j]>=0)
                dp[j]=num[i].ci;
            else{
                int t=j-num[i].hi;
                if(t>=0&&dp[t]>0)
                    dp[j]=dp[t]-1;
            }
        }
    }

    for(int i=40000;i>=0;i--)
    if(dp[i]>=0){
        printf("%d\n",i);break;
    }
	return 0;
}

猜你喜欢

转载自blog.csdn.net/c___c18/article/details/82939102