poj2392多重背包单物品限制

Space Elevator

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions:14013   Accepted: 6697

Description

The cows are going to space! They plan to achieve orbit by building a sort of space elevator: a giant tower of blocks. They have K (1 <= K <= 400) different types of blocks with which to build the tower. Each block of type i has height h_i (1 <= h_i <= 100) and is available in quantity c_i (1 <= c_i <= 10). Due to possible damage caused by cosmic rays, no part of a block of type i can exceed a maximum altitude a_i (1 <= a_i <= 40000). 

Help the cows build the tallest space elevator possible by stacking blocks on top of each other according to the rules.

Input

* Line 1: A single integer, K 

* Lines 2..K+1: Each line contains three space-separated integers: h_i, a_i, and c_i. Line i+1 describes block type i.

Output

* Line 1: A single integer H, the maximum height of a tower that can be built

Sample Input

3
7 40 3
5 23 8
2 52 6

Sample Output

48

Hint

OUTPUT DETAILS: 

From the bottom: 3 blocks of type 2, below 3 of type 1, below 6 of type 3. Stacking 4 blocks of type 2 and 3 of type 1 is not legal, since the top of the last type 1 block would exceed height 40.

Source

USACO 2005 March Gold

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#define inf 0x3f3f3f3f
#define maxn 505
#define maxm 400005
using namespace std;
int n;
struct node
{
    int a,h,c;
}a[maxn];
int dp[maxm];
bool cmp(node a,node b)
{
    return a.a<b.a;
}
int main()
{

        while(~scanf("%d",&n))
        {memset(dp,0,sizeof(dp));

        for(int i=1;i<=n;i++)
        {
            scanf("%d%d%d",&a[i].h,&a[i].a,&a[i].c);
        }
        sort(a+1,a+n+1,cmp);
        int maxx=0;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=a[i].c;j++)
                for(int k=a[i].a;k>=a[i].h;k--)
                {dp[k]=max(dp[k],dp[k-a[i].h]+a[i].h);
                if(dp[k]>maxx)
                    maxx=dp[k];
                }
        }
        printf("%d\n",maxx);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/89070095