POJ 1276 Cash Machine (多重背包)

Cash Machine
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 39126   Accepted: 14224

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example, 

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. 

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. 

Notes: 
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. 

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format: 

cash N n1 D1 n2 D2 ... nN DN 

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. 

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. 

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0

题意:给出每种钱有多少,问最多可以取出不超过m的多少钱来.

思路:多重背包跑一发.

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
#include<cstring>
#include<string>
#include<vector>
#include<map>
using namespace std;
#define mem(a,b) memset(a,b,sizeof(a))
typedef long long ll;
const int maxn = 1e6+5;
const int ff = 0x3f3f3f3f;

int need,n;
int dp[maxn];

int main()
{
	while(~scanf("%d",&need))
	{
		mem(dp,0); 
		scanf("%d",&n);
		int cnt = 0;
		for(int i = 1;i<= n;i++)
		{
			int num,de;
			scanf("%d %d",&num,&de);
			
			int k = 1;
			while(num> k)
			{
				for(int j = need;j>= k*de;j--)
					dp[j] = max(dp[j],dp[j-k*de]+k*de);
				num-= k;
				k*= 2;
			}
			for(int j = need;j>= num*de;j--)
				dp[j] = max(dp[j],dp[j-num*de]+num*de); 
		}
		printf("%d\n",dp[need]);
	}
	
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/nka_kun/article/details/80229570