【POJ 2392】【Space Elevator】

题目:

The cows are going to space! They plan to achieve orbit by building a sort of space elevator: a giant tower of blocks. They have K (1 <= K <= 400) different types of blocks with which to build the tower. Each block of type i has height h_i (1 <= h_i <= 100) and is available in quantity c_i (1 <= c_i <= 10). Due to possible damage caused by cosmic rays, no part of a block of type i can exceed a maximum altitude a_i (1 <= a_i <= 40000). 

Help the cows build the tallest space elevator possible by stacking blocks on top of each other according to the rules.

Input

* Line 1: A single integer, K 

* Lines 2..K+1: Each line contains three space-separated integers: h_i, a_i, and c_i. Line i+1 describes block type i.

Output

* Line 1: A single integer H, the maximum height of a tower that can be built

Sample Input

3
7 40 3
5 23 8
2 52 6

Sample Output

48

Hint

OUTPUT DETAILS: 

From the bottom: 3 blocks of type 2, below 3 of type 1, below 6 of type 3. Stacking 4 blocks of type 2 and 3 of type 1 is not legal, since the top of the last type 1 block would exceed height 40.

题意:一群牛要修建高楼,他们手头有n种建筑材料,之后交代建筑材料的高度,能达到的最大高度(超过就会损坏),数量,求解高楼的最大高度。

解题思路:多重背包,先对建筑材料的能承受的最大高度排序,将承受最大高度小的材料优先放置,才能使结构达到最优,高度达到最大,之后就是多重背包的模板求解。

ac代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define maxn 100005
using namespace std;
int cnt[maxn];
int dp[maxn];
struct node{
	int ht;
	int num;
	int maxx;
}co[maxn];

bool cmp(node a,node b)
{
	return a.maxx<b.maxx;
}
int main()
{
	int k;
	while(scanf("%d",&k)!=EOF)
	{
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=k;i++)
		{
			scanf("%d%d%d",&co[i].ht,&co[i].maxx,&co[i].num);
		}
		sort(co+1,co+1+k,cmp);
		dp[0]=1;
		int ans=0;
		for(int i=1;i<=k;i++)
		{
			memset(cnt,0,sizeof(cnt));
			for(int j=co[i].ht;j<=co[i].maxx;j++)
			{
				if(!dp[j]&&dp[j-co[i].ht]&&cnt[j-co[i].ht]+1<=co[i].num)
				{
					dp[j]=1;
					cnt[j]=cnt[j-co[i].ht]+1;
					if(ans<j) ans=j;
				}
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42505741/article/details/81747052