Coins//POJ - 1742//多重背包

Coins//POJ - 1742//多重背包


题目

People in Silverland use coins.They have coins of value A1,A2,A3…An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn’t know the exact price of the watch.
You are to write a program which reads n,m,A1,A2,A3…An and C1,C2,C3…Cn corresponding to the number of Tony’s coins of value A1,A2,A3…An then calculate how many prices(form 1 to m) Tony can pay use these coins.
Input
The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3…An,C1,C2,C3…Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.
Output
For each test case output the answer on a single line.
Sample Input
3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0
Sample Output
8
4
题意
给定面值和个数,从1到m有多少数能被组成
链接:https://vjudge.net/contest/349029#problem/B

思路

多重背包模板题

代码

#include<cstdio>
#include<cstring>
#include<iostream>
#include<cmath>
#include<string>
#include<queue>
#include<algorithm>
#define mod 1000000007
using namespace std;
typedef long long ll;
const int INF=0x3f3f3f3f;
int n,K;
int a[100050],m[100050];
int dp[100050];
void solve(){
    memset(dp,-1,sizeof(dp));
    dp[0]=0;
    for(int i=0;i<n;i++){
        for(int j=0;j<=K;j++){
            if(dp[j]>=0){
                dp[j]=m[i];
            }
            else if(j<a[i]||dp[j-a[i]]<=0){
                dp[j]=-1;
            }
            else{
                dp[j]=dp[j-a[i]]-1;
            }
        }
    }
    return;
}
int main()
{
    while(cin>>n>>K&&(n||K)){
        memset(a,0,sizeof(a));
        memset(m,0,sizeof(m));
        for(int i=0;i<n;i++){
            cin>>a[i];
        }
        for(int i=0;i<n;i++){
            cin>>m[i];
        }
        solve();
        int cnt=0;
        for(int i=1;i<=K;i++){
            if(dp[i]>=0) cnt++;
        }
        cout<<cnt<<endl;
    }
    return 0;
}

注意

发布了33 篇原创文章 · 获赞 9 · 访问量 2082

猜你喜欢

转载自blog.csdn.net/salty_fishman/article/details/104175593