【poj 2392】Space Elevator(贪心+多重背包)

Space Elevator

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 13340   Accepted: 6323

Description

The cows are going to space! They plan to achieve orbit by building a sort of space elevator: a giant tower of blocks. They have K (1 <= K <= 400) different types of blocks with which to build the tower. Each block of type i has height h_i (1 <= h_i <= 100) and is available in quantity c_i (1 <= c_i <= 10). Due to possible damage caused by cosmic rays, no part of a block of type i can exceed a maximum altitude a_i (1 <= a_i <= 40000). 

Help the cows build the tallest space elevator possible by stacking blocks on top of each other according to the rules.

Input

* Line 1: A single integer, K 

* Lines 2..K+1: Each line contains three space-separated integers: h_i, a_i, and c_i. Line i+1 describes block type i.

Output

* Line 1: A single integer H, the maximum height of a tower that can be built

Sample Input

3
7 40 3
5 23 8
2 52 6

Sample Output

48

Hint

OUTPUT DETAILS: 

From the bottom: 3 blocks of type 2, below 3 of type 1, below 6 of type 3. Stacking 4 blocks of type 2 and 3 of type 1 is not legal, since the top of the last type 1 block would exceed height 40.

 我们先把石头达到的最大高度排序后,这个问题就转化成为了一个完全背包问题。

但是我们这次需要遍历一遍dp数组来求得最大值。(因为最终的高度不确定,即背包的容量就不确定)。

#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
typedef long long ll;
const int maxn = 1000500;
int n,m;
struct node
{
    int h,hh,num;
}s[maxn];
int dp[maxn];
bool cmp(node a,node b)
{
    return a.hh<b.hh;
}
void zopac(int v,int h)//01背包
{
    for(int j=v;j>=h;j--)
    {
        dp[j]=max(dp[j],dp[j-h]+h);
    }
}
void copac(int v,int h)//完全背包
{
    for(int j=h;j<=v;j++)
    {
        dp[j]=max(dp[j],dp[j-h]+h);
    }
}

void mupac(int n)//多重背包
{
    memset(dp,0,sizeof(dp));
    for(int i=0;i<n;i++)
    {
        if(s[i].h*s[i].num>=s[i].hh) copac(s[i].hh,s[i].h);
        else{
            for(int k=1;k<=s[i].num;k<<=1)
            {
                zopac(s[i].hh,k*s[i].h);
                s[i].num-=k;
            }
            if(s[i].num) zopac(s[i].hh,s[i].num*s[i].h);
        }
    }
}
int main()
{
    cin>>n;
    int cnt=0;
    for(int i=0;i<n;i++){
         cin>>s[i].h>>s[i].hh>>s[i].num;
         cnt=max(cnt,s[i].hh);
    }
    sort(s,s+n,cmp);
    mupac(n);
    int ans=0;
    for(int i=0;i<=cnt;i++) ans=max(ans,dp[i]);
    cout<<ans<<endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/duanghaha/article/details/81505392