1025 PAT Ranking (25 分)PAT (Advanced Level) Practice

1025 PAT Ranking (25 分)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

 题目大意:有n个考场,每个考场有若干数量的学生,给出每个考场中考生的编号和分数,要求算排名,

                     输出所有考生的编号、排名、考场号、考场内排名

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct Student{
    char id[14];
    int sore;
    int kid;
    int krank;
}stu[30005];
bool cmp(Student a,Student b){
    if(a.sore!=b.sore)return a.sore>b.sore;
    else return strcmp(a.id,b.id)<0;
}
int main(){
    int n,k,r=0;
    scanf("%d",&n);
    for(int i=1;i<=n;i++){
        scanf("%d",&k);
        for(int j=0;j<k;j++){
            scanf("%s %d",stu[r].id,&stu[r].sore);
            stu[r].kid=i;
            r++;
        }
        sort(stu+r-k,stu+r,cmp);
        stu[r-k].krank=1;
        for(int j=r-k+1;j<r;j++){
            if(stu[j].sore==stu[j-1].sore)stu[j].krank=stu[j-1].krank;
            else stu[j].krank=j-(r-k)+1;
        }
    }
    sort(stu,stu+r,cmp);
    printf("%d\n",r);
    int rank=1;
    for(int i=0;i<r;i++){
        if(i>0&&stu[i].sore!=stu[i-1].sore)rank=i+1;
        printf("%s %d %d %d\n",stu[i].id,rank,stu[i].kid,stu[i].krank);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/mlm5678/article/details/83001587