1117 Eddington Number(25 分)(cj)

1117 Eddington Number(25 分)

British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an "Eddington number", E -- that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington's own E was 87.

Now given everyday's distances that one rides for N days, you are supposed to find the corresponding E (≤N).

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.

Output Specification:

For each case, print in a line the Eddington number for these N days.

Sample Input:

10
6 7 6 9 3 10 8 2 7 8

Sample Output:

6

emmmmm

这是我写的最短的25分题吧。。 

code

#pragma warning(disable:4996)
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
bool cmp(const int& x, const int& y) {
	return x > y;
}
int main() {
	int n, x;
	cin >> n;
	vector<int> varr;
	for (int i = 0; i < n; ++i) {
		cin >> x;
		varr.push_back(x);
	}
	sort(varr.begin(), varr.end(), cmp);
	bool f = 1;
	for (int i = 0; i < varr.size(); ++i) {
		if (i+1 >= varr[i]) {
			cout << i << endl;
			f = 0;
			break;
		}
	}
	if (f) cout << n << endl;
	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Cute_jinx/article/details/82627924