PAT 1117 Eddington Number(25 分)

British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an "Eddington number", E -- that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington's own E was 87.

Now given everyday's distances that one rides for N days, you are supposed to find the corresponding E (≤N).

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.

Output Specification:

For each case, print in a line the Eddington number for these N days.

Sample Input:

10
6 7 6 9 3 10 8 2 7 8

Sample Output:

6

思路:从小到大排序,E从大到小考虑,只需要E个数中考虑最小的那个数,即v[n-E]是否大于E就行,不成立,E就减一;

程序:

#include <cstdio>
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int main()
{
  int n;
  scanf("%d",&n);
  vector<int> v;
  for(int i = 0; i < n; i++)
  {
    int a;
    scanf("%d",&a);
    v.push_back(a);
  }
  sort(v.begin(),v.end());
  int E = v.size();
  while(E)
  {
    if(v[n-E] <= E)
      E--;
    else
     break;
  }
  printf("%d\n",E);
  return 0;
}

猜你喜欢

转载自blog.csdn.net/Hickey_Chen/article/details/81095463