1117 Eddington Number (25分)

British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an "Eddington number", E -- that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington's own E was 87.

Now given everyday's distances that one rides for N days, you are supposed to find the corresponding E (≤N).

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.

Output Specification:

For each case, print in a line the Eddington number for these N days.

Sample Input:

10
6 7 6 9 3 10 8 2 7 8

Sample Output:

6

题意:有N天的骑行距离,其中找个最大整数E(E<=N)满足有E天每天骑行距离均大于E。

思路:常规方法超时,可以用数组index来记录每个骑行距离有多少天,从1开始遍历,累加数组值,超过E距离的天数就等于【总天数 -  数组累加值(也即小于等于的天数)】 若超过天数 <= E,保存E,若超过天数 > E,则结束循环,输出保存的最后一个E即可。(逻辑有点儿绕,静下心来好好想想~)

#include<iostream>
#include<vector>


using namespace std;


int main(){

    int n;
    cin >> n;

    int a[100010] = {0};

    for(int i = 0; i < n; i++){
        int temp;
        scanf("%d", &temp);
        if(temp <= 100000 )
            a[temp]++;

    }
    int flag = 0;
    if(n == 0){
        printf("0\n");
        return 0;

    }else
    {
        int cnt = 0;
        
        for(int i = 1; i <=n; i++){
            cnt += a[i];
            if(i <= n - cnt){
                flag = i;
            }else
            {
                printf("%d\n", flag);
                return 0;
            }
            

        }
    }
    printf("%d\n", flag);
    
    
    return 0;
}
发布了86 篇原创文章 · 获赞 15 · 访问量 1128

猜你喜欢

转载自blog.csdn.net/zbchenchanghao/article/details/104129213