PAT (Advanced Level) Practice 1093 Count PAT's (25分)

1.题目

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT's contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 10​5​​ characters containing only PA, or T.

Output Specification:

For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:

APPAPT

Sample Output:

2

2.题目分析 

 PAT (Basic Level) Practice 1040 有几个PAT (25分) 数学规律

3.代码

#include<iostream>
#include<string>
#include<cstring>
using namespace std;
int main()
{
	string temp;
	cin >> temp;
	long long int total = 0;
	for (int i = 0; i < temp.length(); i++)
		if (temp[i] == 'T')total++;

	long long int pcount = 0, tcount = 0, count = 0;
	for (int i = 0; i < temp.length(); i++)
	{
		if (temp[i] == 'P')pcount++;
		else if (temp[i] == 'T')tcount++;
		else count = count + pcount*(total-tcount);
	}
	cout << count % 1000000007;
	

}
发布了203 篇原创文章 · 获赞 4 · 访问量 5689

猜你喜欢

转载自blog.csdn.net/qq_42325947/article/details/105455521